Back to overview
Downtime
Samverse, MiiPage and the wiki are down
Apr 18, 2026 at 10:50pm UTC
Affected services
Samverse
Wiki
MiiPage
Resolved
Apr 22, 2026 at 3:40pm UTC
All services are back online. Thank you for your patience!
Affected services
Updated
Apr 21, 2026 at 6:03pm UTC
We have identified the issue and are working with Amazon to resolve it.
Affected services
Created
Apr 18, 2026 at 10:50pm UTC
This was all caused by an issue related to forgotten renewal of servers. We are working with Amazon to get these restored.
Affected services