Back to overview
Degraded

Main website is slow

May 18, 2026 at 7:57pm UTC
Affected services
Main Website

Resolved
May 19, 2026 at 7:45pm UTC

The issue has been resolved.

Created
May 18, 2026 at 7:57pm UTC

We are working to solve the issue.